<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head><meta charset="UTF-8" /><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
    <title>Slick Fujifilm X-H2S mirrorless camera now available for pre-order on Amazon | Stark Insider</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%2C600%2C700%7COpen%20Sans%20Condensed%3A400%7CRoboto%20Condensed%3A400%2C500%2C700&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%2C600%2C700%7COpen%20Sans%20Condensed%3A400%7CRoboto%20Condensed%3A400%2C500%2C700&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%2C600%2C700%7COpen%20Sans%20Condensed%3A400%7CRoboto%20Condensed%3A400%2C500%2C700&#038;display=swap" /></noscript><style id="rocket-critical-css">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</style>
    
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.starkinsider.com/xmlrpc.php" />
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="icon" type="image/png" href="https://cloud.starkinsider.com/favicon.ico"><link rel="apple-touch-icon" sizes="76x76" href="https://cloud.starkinsider.com/wp-content/uploads/2016/02/IN-Logo-Feb-2016-76px.png"/><link rel="apple-touch-icon" sizes="120x120" href="https://cloud.starkinsider.com/wp-content/uploads/2016/02/IN-Logo-Feb-2016-120px.png"/><link rel="apple-touch-icon" sizes="152x152" href="https://cloud.starkinsider.com/wp-content/uploads/2016/02/IN-Logo-Feb-2016-152px.png"/><link rel="apple-touch-icon" sizes="114x114" href="https://cloud.starkinsider.com/wp-content/uploads/2016/02/IN-Logo-Feb-2016-114px.png"/><link rel="apple-touch-icon" sizes="144x144" href="https://cloud.starkinsider.com/wp-content/uploads/2016/02/IN-Logo-Feb-2016-144px.png"/>
	<!-- This site is optimized with the Yoast SEO Premium plugin v18.7 (Yoast SEO v19.1) - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Attention shoppers: Your shiny new Fujifilm X-H2s is almost here. The mirrorless camera was recently announced by Fuji and by my estimations it&#039;s been" />
	<link rel="canonical" href="https://www.starkinsider.com/2022/06/slick-fujifilm-x-h2s-mirrorless-camera-now-available-for-pre-order-on-amazon.html" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Slick Fujifilm X-H2S mirrorless camera now available for pre-order on Amazon" />
	<meta property="og:description" content="Attention shoppers: Your shiny new Fujifilm X-H2s is almost here. The mirrorless camera was recently announced by Fuji and by my estimations it&#039;s been" />
	<meta property="og:url" content="https://www.starkinsider.com/2022/06/slick-fujifilm-x-h2s-mirrorless-camera-now-available-for-pre-order-on-amazon.html" />
	<meta property="og:site_name" content="Stark Insider" />
	<meta property="article:published_time" content="2022-06-20T18:40:08+00:00" />
	<meta property="article:modified_time" content="2022-06-20T18:57:18+00:00" />
	<meta property="og:image" content="https://cloud.starkinsider.com/wp-content/uploads/2022/06/Fujifilm-X-H2S-mirrorless-camera-video-GH6-sony-scaled.jpg" />
	<meta property="og:image:width" content="2560" />
	<meta property="og:image:height" content="1439" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@https://www.twitter.com/clintonstark" />
	<meta name="twitter:site" content="@starkinsider" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Clinton Stark" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//www.starkinsider.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel='dns-prefetch' href='//google-analytics.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//ssl.google-analytics.com' />
<link rel='dns-prefetch' href='//youtube.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//cloud.starkinsider.com' />
<link rel='dns-prefetch' href='//cloud2.starkinsider.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link href='//cloud.starkinsider.com' rel='preconnect' />
<link href='//cloud2.starkinsider.com' rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Stark Insider &raquo; Feed" href="https://www.starkinsider.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Stark Insider &raquo; Comments Feed" href="https://www.starkinsider.com/comments/feed" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='preload'   href='https://cloud2.starkinsider.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')"  type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>

<link data-minify="1" rel='preload'   href='https://cloud2.starkinsider.com/wp-content/cache/min/1/wp-content/themes/Newsmag/style.css?ver=1654713411' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')"  type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link data-minify="1" rel='preload'   href='https://cloud2.starkinsider.com/wp-content/cache/min/1/wp-content/themes/Newsmag-child/style.css?ver=1654713411' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')"  type='text/css' media='all' />
<link data-minify="1" rel='preload'   href='https://cloud2.starkinsider.com/wp-content/cache/min/1/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=1654713411' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')"  type='text/css' media='all' />
<link data-minify="1" rel='preload'   href='https://cloud2.starkinsider.com/wp-content/cache/min/1/wp-content/plugins/td-composer/legacy/Newsmag/assets/css/td_legacy_main.css?ver=1654713411' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')"  type='text/css' media='all' />
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://cloud2.starkinsider.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://cloud2.starkinsider.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://www.starkinsider.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.starkinsider.com/wp-json/wp/v2/posts/217813" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.starkinsider.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.starkinsider.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0" />
<link rel='shortlink' href='https://www.starkinsider.com/?p=217813' />
<link rel="alternate" type="application/json+oembed" href="https://www.starkinsider.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.starkinsider.com%2F2022%2F06%2Fslick-fujifilm-x-h2s-mirrorless-camera-now-available-for-pre-order-on-amazon.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.starkinsider.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.starkinsider.com%2F2022%2F06%2Fslick-fujifilm-x-h2s-mirrorless-camera-now-available-for-pre-order-on-amazon.html&#038;format=xml" />
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    			<script type="rocketlazyloadscript">
				window.tdwGlobal = {"adminUrl":"https:\/\/www.starkinsider.com\/wp-admin\/","wpRestNonce":"bef41e0433","wpRestUrl":"https:\/\/www.starkinsider.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%postname%.html"};
			</script>
			<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>

<!-- JS generated by theme -->

<script type="rocketlazyloadscript">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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script type="rocketlazyloadscript">
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-4059533-6', 'auto');
ga('send', 'pageview');
ga('set', 'displayFeaturesTask', null);
</script>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script type="rocketlazyloadscript" async src="https://www.googletagmanager.com/gtag/js?id=G-Y23FPEJW9Q"></script>
<script type="rocketlazyloadscript">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-Y23FPEJW9Q');
</script><noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	<style id="tdw-css-placeholder"></style><script type="rocketlazyloadscript">
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>

<body class="post-template-default single single-post postid-217813 single-format-standard slick-fujifilm-x-h2s-mirrorless-camera-now-available-for-pre-order-on-amazon global-block-template-1 single_template_3 wpb-js-composer js-comp-ver-6.9.0 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up  td-hide-scroll-up-on-mob"  style="display:none;"><i class="td-icon-menu-up"></i></div>

    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.twitter.com/starkinsider" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.vimeo.com/starkinsider" title="Vimeo">
                <i class="td-icon-font td-icon-vimeo"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/subscription_center?add_user=starksilvercreek" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-stark-insider-container"><ul id="menu-stark-insider" class="td-mobile-main-menu"><li id="menu-item-170508" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-170508"><a title="Indie film, music, arts in San Francisco" href="https://www.starkinsider.com/culture">Culture</a></li>
<li id="menu-item-205382" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-205382"><a title="Fitness, travel, food &#038; wine and clean air" href="https://www.starkinsider.com/lifestyle">Lifestyle</a></li>
<li id="menu-item-158803" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-158803"><a title="Tech stories, camera news &#038; reviews" href="https://www.starkinsider.com/tech">Filmmaking/Tech</a></li>
<li id="menu-item-197903" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-197903"><a title="Short films and experimental videos by Clinton Stark and Loni Stark" href="https://www.starkinsider.com/atelier-stark-films">Atelier Stark Films</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://www.starkinsider.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    <div id="td-outer-wrap">
    
        <div class="td-outer-container">
        
            <!--
Header style 5
-->
<div class="td-header-wrap td-header-style-5">
    <div class="td-top-menu-full">
        <div class="td-header-row td-header-top-menu td-make-full">
            
    <div class="td-top-bar-container top-bar-style-4">
            <div class="td-header-sp-top-widget">
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.twitter.com/starkinsider" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.vimeo.com/starkinsider" title="Vimeo">
                <i class="td-icon-font td-icon-vimeo"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/subscription_center?add_user=starksilvercreek" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>    </div>
            <div class="td-header-sp-top-menu">

    <div class="menu-top-container"><ul id="menu-stark-insider-top" class="top-header-menu"><li id="menu-item-158883" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-158883"><a title="About Stark Insider" href="/about">About</a></li>
</ul></div></div>    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim td-login-modal-wrap">
                    <div class="td-login-wrap">
                        <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <form id="loginForm" action="#" method="post">
                                <div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div>
                                <div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div>
                                <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                                
                            </form>
                            
                            

                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            <div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.starkinsider.com/about/privacy-policy">Privacy Policy</a></div>
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <form id="forgotpassForm" action="#" method="post">
                                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div>
                                <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            </form>
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap">
        <div class="td-header-row td-header-main-menu">
            <div class="td-make-full">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#" aria-label="mobile-toggle"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
                <a class="td-main-logo" href="https://www.starkinsider.com/">
            <img width="350" height="76" class="td-retina-data" data-retina="https://cloud.starkinsider.com/wp-content/uploads/2021/03/stark-insider-retina-logo_350.png" src="https://cloud.starkinsider.com/wp-content/uploads/2021/03/stark-insider-retina-logo_350.png" alt="Stark Insider - Arts, Film, Tech & Lifestyle"/>
            <span class="td-visual-hidden">Stark Insider</span>
        </a>
        </div>
    <div class="menu-stark-insider-container"><ul id="menu-stark-insider-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-170508"><a title="Indie film, music, arts in San Francisco" href="https://www.starkinsider.com/culture">Culture</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-205382"><a title="Fitness, travel, food &#038; wine and clean air" href="https://www.starkinsider.com/lifestyle">Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-normal-menu menu-item-158803"><a title="Tech stories, camera news &#038; reviews" href="https://www.starkinsider.com/tech">Filmmaking/Tech</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-197903"><a title="Short films and experimental videos by Clinton Stark and Loni Stark" href="https://www.starkinsider.com/atelier-stark-films">Atelier Stark Films</a></li>
</ul></div></div>

<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" aria-label="search icon" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" aria-label="search icon" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search">
			<form method="get" class="td-search-form" action="https://www.starkinsider.com/">
				<div role="search" class="td-head-form-search-wrap">
					<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-header-container">
        <div class="td-header-row td-header-header">
            <div class="td-header-sp-rec">
                
<div class="td-header-ad-wrap  td-ad">
    

</div>            </div>
        </div>
    </div>
</div><div class="td-container td-post-template-3">
    <div class="td-container-border">
        <article id="post-217813" class="post-217813 post type-post status-publish format-standard has-post-thumbnail hentry category-filmmaking category-news tag-canon tag-fujifilm tag-fujifilm-x-h2s tag-panasonic tag-panasonic-lumix-gh5 tag-panasonic-lumix-gh6 tag-panasonic-lumix-s5 tag-red tag-sony" itemscope itemtype="https://schema.org/Article">
            <div class="td-pb-row">
                <div class="td-pb-span12">
                    <div class="td-post-header td-pb-padding-side">
                        
                        <ul class="td-category"><li class="entry-category"><a  href="https://www.starkinsider.com/tech">Tech</a></li><li class="entry-category"><a  href="https://www.starkinsider.com/tech/filmmaking">Filmmaking</a></li></ul>
                        <header>
                            <h1 class="entry-title">Slick Fujifilm X-H2S mirrorless camera now available for pre-order on Amazon</h1>

                


                            <div class="meta-info">

                                <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.starkinsider.com/author/admin">Clinton Stark</a><div class="td-author-line"> - </div> </div>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-20T11:40:08-07:00" >06.20.2022</time></span>                                                            </div>
                        </header>
                    </div>
                </div>
            </div> <!-- /.td-pb-row -->

            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
    <div class="td-post-featured-image"><img width="681" height="383" class="entry-thumb" src="https://cloud.starkinsider.com/wp-content/uploads/2022/06/Fujifilm-X-H2S-mirrorless-camera-video-GH6-sony-681x383.jpg" srcset="https://cloud.starkinsider.com/wp-content/uploads/2022/06/Fujifilm-X-H2S-mirrorless-camera-video-GH6-sony-681x383.jpg 681w, https://cloud.starkinsider.com/wp-content/uploads/2022/06/Fujifilm-X-H2S-mirrorless-camera-video-GH6-sony-1200x674.jpg 1200w, https://cloud.starkinsider.com/wp-content/uploads/2022/06/Fujifilm-X-H2S-mirrorless-camera-video-GH6-sony-768x432.jpg 768w, https://cloud.starkinsider.com/wp-content/uploads/2022/06/Fujifilm-X-H2S-mirrorless-camera-video-GH6-sony-1536x863.jpg 1536w, https://cloud.starkinsider.com/wp-content/uploads/2022/06/Fujifilm-X-H2S-mirrorless-camera-video-GH6-sony-640x360.jpg 640w" sizes="(max-width: 681px) 100vw, 681px" alt="Fujifilm X H2S mirrorless camera video thoughts" title="Fujifilm X H2S mirrorless camera video thoughts"/></div>
			
    <div class="td-post-content td-pb-padding-side">
        <p>Attention shoppers:</p>
<p>Your shiny new Fujifilm X-H2s is almost here.</p>
<p>The mirrorless camera was recently announced by Fuji and by my estimations it&#8217;s been impressing the camera cohort.</p>
<p>Now you can <a href="https://amzn.to/3bhNRVD">pre-order the Fujifilm X-H2S on Amazon</a>. The camera is expected to ship next month, just in time for wedding season no less.</p>
<p>For an APS-C sensor the price might seem steep at first ($2,499 USD). And it is, at least if you compare it to some of its most obvious competitors &#8212; not too mention consider the supply chain and pandemic-related issues.</p>
<p>Favorite among YouTubers, wedding shooters and videographers, <a href="https://amzn.to/3QwRcQF">the Sony a7 IV</a>, for instance, retails for the same price (at least here Stateside). For that, however, you get a full-frame sensor and what I suspect is a more common E-mount lens mount (vs. X for the Fuji). Or you could opt for another full-frame camera in the Panasonic S5. At only $1,998 it&#8217;s an enticing choice given its price and Panasonic&#8217;s rich pedigree in film and video.</p>
<p>Nevertheless, for me at least, the X-H2S is a standout in the field (so long as tests prove out the specs!).</p>
<p>One slick feature is the ability to record externally to Blackmagic BRAW using a Blackmagic Video Assist monitor, or to ProRes RAW using an Atomos Ninja V+ monitor. That flexibility is great. Choose your favorite flavor and off you go. I&#8217;d assume many video enthusiasts already own one of those monitors so you&#8217;ll be ready to go from the get-go.</p>
<p>Of note in terms of the X-H2S design is Fuji&#8217;s decision to do away with its standard photo-centric controls and dials along the top plate. Instead you&#8217;ll find something simpler: a mode dial, and various buttons and controls more in keeping with videography. For instance, there&#8217;s no ISO wheel. That&#8217;s something you simply wouldn&#8217;t tweak as often for video as you might for photography &#8212; though there is an ISO button so changing it is almost as easy in any case.</p>
<p>As you might expect this new Fuji delivers in terms of specs.</p>
<p>You can shoot video up to 6.2K/30 in open gate 3:2, 4K/120, and for the hardcore slowmo fiends even up to HD/240. It remains to be seen what the quality will look like when the production models ship, but safe to say it&#8217;s nice to have the options in hand.</p>
<p>There are a few caveats.</p>
<p>So far as I know there&#8217;s no waveform option on the monitor. And the shutter control can not be set to angle (ie. 180-degree filmmaking standard). Instead you&#8217;ll need to go with something like 1/48 and change according to your frame rate. The <a href="https://fujifilm-x.com/en-us/products/cameras/x-h2s/">X-H2 manual doesn&#8217;t appear available to download on Fujifilm&#8217;s web site</a> (yet) so I can&#8217;t absolutely confirm these or not as of this writing so keep that in consideration.</p>
<p>Also, I&#8217;m not quite sure what the X-H2S offers in terms of focus peaking options. I shoot video manual all the time. 7/24! So that&#8217;s an important feature for me. I was eternally thankful RED finally updated its camera firmwares in recent years with focus peaking.</p>
<blockquote>
<h2><strong><a href="https://www.starkinsider.com"><img class="alignright wp-image-206337" src="https://cloud.starkinsider.com/wp-content/uploads/2020/10/Stark-Insider-Favicon-2020-200x200-1.png" alt="Stark Insider - Arts, Film, Tech &amp; LifestyleStark Insider - Arts, Film, Tech &amp; Lifestyle" width="72" height="64" /></a>FUJIFILM X-H2S Key Features</strong></h2>
<p><img class="alignnone  wp-image-217841" src="https://cloud.starkinsider.com/wp-content/uploads/2022/06/FUJIFILM-X-H2S-mirrorless-camera-specs-video-681x454.jpg" alt="FUJIFILM X-H2S mirrorless camera specs video" width="367" height="383" /></p>
<ul>
<li>26.1MP APS-C X-Trans Stacked BSI Sensor</li>
<li>4K 120p, 6.2K 30p, FHD 240p 10-Bit Video</li>
<li>Internal ProRes 422 HQ and F-Log 2</li>
<li>7-Stop In-Body Image Stabilization</li>
<li>5.76m-Dot OLED Electronic Viewfinder</li>
<li>3&#8243; 1.62m-Dot Vari-Angle Touchscreen LCD</li>
<li>40 fps E. Shutter, 15 fps Mech. Shutter</li>
<li>425-Pt. Hybrid AF, AI Subject Detection</li>
<li>Dual memory card slots: CFexpress Type B, SD UHS-II</li>
<li>ProRes &amp; Blackmagic RAW via HDMI</li>
<li>Full-size HDMI port</li>
<li>USB-C 3.2 Gen 2</li>
<li>Film Simulation Modes</li>
<li>MSRP: $2,499 USD</li>
<li>Availability: July 2022</li>
</ul>
</blockquote>
<p>Above all else, though, the one thing that might put this little Fuji ahead of the likes of Sony, Panasonic and Canon may well be the fabled image its sensor provides. There&#8217;s something <em>je ne sais quoi</em> about Fujis. Certainly, when I owned and shot a lot for Stark Insider with the Panasonic GH5 I found that sensor too digital &#8212; too clean. So I had to grain it up in post. That&#8217;s a personal preference so ymmv. In the case of the X-H2 I&#8217;m expecting beautiful colors and a very pleasing organic image. I recommend completely turning off in-camera image processing such as noise reduction, or sharpening.</p>
<p>I think a lot of videographers, filmmakers, wedding and music video shooters, and corporate crews will at least shortlist the X-H2S. The lens mount (X) may well be its Achilles heal. Large operations are probably invested in Canon EF (and now RF) and Sony E-mount glass so that might be a financially insurmountable obstacle which is why I believe this one will appeal more to solo operators and smaller production teams.</p>
<p>I&#8217;m glad I held off on a Panasonic GH6 purchase. That&#8217;s a fine camera no doubt. I absolutely adored its successor in the GH5. However, I&#8217;m a sucker for organic imagery and vivid colors (hence, on this latter point why I still think Canon is an excellent option in 2022 and beyond).</p>
<p>Internal ProRes 4:2:2 and the external RAW options (Blackmagic and ProRes) are very compelling features, and I think set this camera apart.</p>
<p>Also, another point in its favor: if you do indeed want to use it as a hybrid and take occasional photos the APS-C sensor will likely be appreciated over the small, cropped Micro Four Thirds one found on the GH5/GH6.</p>
<p>Further if you&#8217;ve always lusted after the Fujifilm MKX18-55mm cinema lens note that you can buy a kit which nets you that lens with $1,000 savings. That means you&#8217;re still paying about $3,000 USD for it, but that&#8217;s 25% off, a not insignificant amount of savings if you&#8217;ve had this one on your radar (I have!).</p>
<p>All that to say, the Fujifilm X-H2S is <a href="https://amzn.to/3y6s4ci">available now for pre-order on Amazon</a>.</p>
<p>Smartphones are still crushing the dedicated camera market. Regardless, I think a niche for these sorts of cameras will continue to exist &#8212; and they&#8217;ll likely remain expensive to differentiate from the lower cost iPhones of the world.</p>
<p>Happy shooting!</p>
    </div>


    <footer>
        
        <div class="td-post-source-tags td-pb-padding-side">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.starkinsider.com/tag/canon">Canon</a></li><li><a href="https://www.starkinsider.com/tag/fujifilm">Fujifilm</a></li><li><a href="https://www.starkinsider.com/tag/fujifilm-x-h2s">Fujifilm X-H2S</a></li><li><a href="https://www.starkinsider.com/tag/panasonic">Panasonic</a></li><li><a href="https://www.starkinsider.com/tag/panasonic-lumix-gh5">Panasonic Lumix GH5</a></li><li><a href="https://www.starkinsider.com/tag/panasonic-lumix-gh6">Panasonic Lumix GH6</a></li><li><a href="https://www.starkinsider.com/tag/panasonic-lumix-s5">Panasonic Lumix S5</a></li><li><a href="https://www.starkinsider.com/tag/red">RED (Red Digital Cinema Camera Company)</a></li><li><a href="https://www.starkinsider.com/tag/sony">Sony</a></li></ul>        </div>

        <div class="author-box-wrap"><a href="https://www.starkinsider.com/author/admin" aria-label="author-photo"><img alt='' src='https://secure.gravatar.com/avatar/470b4cfeb30f29e07e15ba90ac2b47ed?s=96&#038;d=identicon&#038;r=pg' srcset='https://secure.gravatar.com/avatar/470b4cfeb30f29e07e15ba90ac2b47ed?s=192&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-96 photo' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.starkinsider.com/author/admin">Clinton Stark</a></span></div><div class="td-author-description">Clinton shoots <a href="https://www.vimeo.com/starkinsider">videos for Stark Insider</a>. Interests include San Francisco arts, hi-res audio, Ingmar Bergman, and ranting about photo realism. <b>Peloton:</b> ClintTheMint. <b>Camera:</b> <a href="https://www.starkinsider.com/camera-gear-list-shooting-video-clinton-stark">Video Gear</a></div><div class="td-author-social">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.twitter.com/clintonstark" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://vimeo.com/starkinsider" title="Vimeo">
                <i class="td-icon-font td-icon-vimeo"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/starkinsider" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span></div><div class="clearfix"></div></div></div>	    <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Clinton Stark"><meta itemprop="url" content="https://www.starkinsider.com/author/admin"></span><meta itemprop="datePublished" content="2022-06-20T11:40:08-07:00"><meta itemprop="dateModified" content="2022-06-20T11:57:18-07:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.starkinsider.com/2022/06/slick-fujifilm-x-h2s-mirrorless-camera-now-available-for-pre-order-on-amazon.html"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://cloud.starkinsider.com/wp-content/uploads/2021/03/stark-insider-retina-logo_350.png"></span><meta itemprop="name" content="Stark Insider"></span><meta itemprop="headline " content="Slick Fujifilm X-H2S mirrorless camera now available for pre-order on Amazon"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://cloud.starkinsider.com/wp-content/uploads/2022/06/Fujifilm-X-H2S-mirrorless-camera-video-GH6-sony-scaled.jpg"><meta itemprop="width" content="2560"><meta itemprop="height" content="1439"></span>    </footer>


                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar td-pb-border-top" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="margin-top:20px;display: block;width:100%;margin-left:auto;margin-right:auto;"><a href="https://www.youtube.com/subscription_center?add_user=starksilvercreek" target="_blank" rel="noopener"><img width="300" height="300" src="https://cloud.starkinsider.com/wp-content/uploads/2020/11/stark-insider-loni-stark-in-a-west-coast-adventure-film-300x300-1.jpg" alt="Stark Insider. Loni Stark in A West Coast Adventure. A Lifetime in the Making." style="width:300px;height:300px;"/></a></div>
</div></aside>                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
        </article> <!-- /.post -->
    </div>
</div> <!-- /.td-container -->

    <!-- Instagram -->
    

    <!-- Footer -->
    <div class="td-footer-container td-container">

	<div class="td-pb-row">
		<div class="td-pb-span12">
					</div>
	</div>

	<div class="td-pb-row">
		<div class="td-pb-span8">
			<div class="td-footer-info td-pb-padding-side"><div class="footer-logo-wrap"><a href="https://www.starkinsider.com/"><img width="1000" height="214" class="td-retina-data" src="https://cloud.starkinsider.com/wp-content/uploads/2020/12/Stark-Insider-is-All-Things-West-Coast-Footer-Retina@2x.png" data-retina="https://cloud.starkinsider.com/wp-content/uploads/2020/12/Stark-Insider-is-All-Things-West-Coast-Footer-Retina@2x.png" alt="Stark Insider - All Things West Coast" title=""  /></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style2"></div></div><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><h3 style="text-align: center; font-size: 22px; line-height: 24px; letter-spacing: 1px;"><span style="color: #fff;"><em>A WEST COAST ADVENTURE</em></span></h3>
<h3 style="text-align: center; font-size: 22px; line-height: 24px;  letter-spacing: 1px;margin-bottom:140px"><span style="color: #fff;"><em>A LIFETIME IN THE MAKING</em></span></h3></div></aside>		</div>

		<div class="td-pb-span4">
					</div>
	</div>
</div>

    <!-- Sub Footer -->
        <div class="td-sub-footer-container td-container td-container-border ">
        <div class="td-pb-row">
            <div class="td-pb-span8 td-sub-footer-menu">
                <div class="td-pb-padding-side">
                    <div class="menu-footer-container"><ul id="menu-footer" class="td-subfooter-menu"><li id="menu-item-183438" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-183438"><a href="https://www.starkinsider.com">STARK INSIDER</a></li>
<li id="menu-item-161130" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-161130"><a href="/about/samples-and-product-review-policy">Samples Policy &#038; Shipping Address</a></li>
<li id="menu-item-161129" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-161129"><a href="/about/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-161128" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-161128"><a href="/about/advertising">Advertise</a></li>
<li id="menu-item-161127" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-161127"><a href="/about/contact">Contact</a></li>
<li id="menu-item-161126" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-161126"><a href="/about">About</a></li>
</ul></div>                </div>
            </div>

            <div class="td-pb-span4 td-sub-footer-copy">
                <div class="td-pb-padding-side">
                    &copy; Copyright 2005-2022 BLG Media LLC. v14                </div>
            </div>
        </div>
    </div>
    </div><!--close td-outer-container-->
</div><!--close td-outer-wrap-->



    <!--

        Theme: Newsmag by tagDiv.com 2022
        Version: 5.2.1 (rara)
        Deploy mode: deploy
        
        uid: 62b0c330759b8
    -->

    <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://cloud2.starkinsider.com/wp-content/plugins/td-composer/legacy/Newsmag/js/tagdiv_theme.min.js?ver=5.2.1' id='td-site-min-js'></script>

<!-- JS generated by theme -->

<script type="rocketlazyloadscript">
    
</script>


<script>"use strict";function wprRemoveCPCSS(){var preload_stylesheets=document.querySelectorAll('link[data-rocket-async="style"][rel="preload"]');if(preload_stylesheets&&0<preload_stylesheets.length)for(var stylesheet_index=0;stylesheet_index<preload_stylesheets.length;stylesheet_index++){var media=preload_stylesheets[stylesheet_index].getAttribute("media")||"all";if(window.matchMedia(media).matches)return void setTimeout(wprRemoveCPCSS,200)}var elem=document.getElementById("rocket-critical-css");elem&&"remove"in elem&&elem.remove()}window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><noscript><link rel='stylesheet' id='wp-block-library-css'  href='https://cloud2.starkinsider.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='td-theme-css'  href='https://cloud2.starkinsider.com/wp-content/cache/min/1/wp-content/themes/Newsmag/style.css?ver=1654713411' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='td-theme-child-css'  href='https://cloud2.starkinsider.com/wp-content/cache/min/1/wp-content/themes/Newsmag-child/style.css?ver=1654713411' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='js_composer_front-css'  href='https://cloud2.starkinsider.com/wp-content/cache/min/1/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=1654713411' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://cloud2.starkinsider.com/wp-content/cache/min/1/wp-content/plugins/td-composer/legacy/Newsmag/assets/css/td_legacy_main.css?ver=1654713411' type='text/css' media='all' /></noscript></body>
</html><!--
Performance optimized by Redis Object Cache. Learn more: https://wprediscache.com

Retrieved 2884 objects (11 MB) from Redis using PhpRedis (v5.1.1).
-->

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1655751472 -->